#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=at point, )(X=(?:\d|\.)+) +\K(Y=(?:\d|\.)+).*?\K(value \w+)\R +\K(tag \w+)\K"
Local $sString = "[ AutoCAD - Thu Sep 03 15:59:09 2020 ]----------------------------------------" & @CRLF & _
"" & @CRLF & _
"Command: LIST" & @CRLF & _
"" & @CRLF & _
"Select objects: Specify opposite corner: 468 found" & @CRLF & _
"" & @CRLF & _
"Select objects: " & @CRLF & _
"" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal" & @CRLF & _
" BLOCK REFERENCE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Block Name: "Block"" & @CRLF & _
" at point, X=1378.4556 Y=1314.2124 Z= 0.0000" & @CRLF & _
" X scale factor: 16.5000" & @CRLF & _
" Y scale factor: 16.5000" & @CRLF & _
" rotation angle: 160.67" & @CRLF & _
" Z scale factor: 266.0000" & @CRLF & _
" Scale uniformly: No" & @CRLF & _
" Allow exploding: Yes" & @CRLF & _
"" & @CRLF & _
" ATTRIBUTE Layer: "layer1"" & @CRLF & _
" Space: Model space" & @CRLF & _
" Handle = 12345" & @CRLF & _
" Style = "STANDARD" " & @CRLF & _
" Annotative: No" & @CRLF & _
" Font file = default.shx " & @CRLF & _
" substituted by default.shx" & @CRLF & _
" start point, X=1365.1222 Y=1319.6510 Z= 0.0000" & @CRLF & _
" height 3.0000" & @CRLF & _
" value 2999" & @CRLF & _
" tag THINGY" & @CRLF & _
" rotation angle 340.67" & @CRLF & _
" width scale factor 1.0000" & @CRLF & _
" obliquing angle 0.00" & @CRLF & _
" flags normal" & @CRLF & _
" generation normal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")