import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=at point, )(X=(?:\\d|\\.)+) +\\K(Y=(?:\\d|\\.)+).*?\\K(value \\w+)\\R +\\K(tag \\w+)\\K";
final String string = "[ AutoCAD - Thu Sep 03 15:59:09 2020 ]----------------------------------------\n\n"
+ "Command: LIST\n\n"
+ "Select objects: Specify opposite corner: 468 found\n\n"
+ "Select objects: \n\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal\n"
+ " BLOCK REFERENCE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Block Name: \"Block\"\n"
+ " at point, X=1378.4556 Y=1314.2124 Z= 0.0000\n"
+ " X scale factor: 16.5000\n"
+ " Y scale factor: 16.5000\n"
+ " rotation angle: 160.67\n"
+ " Z scale factor: 266.0000\n"
+ " Scale uniformly: No\n"
+ " Allow exploding: Yes\n\n"
+ " ATTRIBUTE Layer: \"layer1\"\n"
+ " Space: Model space\n"
+ " Handle = 12345\n"
+ " Style = \"STANDARD\" \n"
+ " Annotative: No\n"
+ " Font file = default.shx \n"
+ " substituted by default.shx\n"
+ " start point, X=1365.1222 Y=1319.6510 Z= 0.0000\n"
+ " height 3.0000\n"
+ " value 2999\n"
+ " tag THINGY\n"
+ " rotation angle 340.67\n"
+ " width scale factor 1.0000\n"
+ " obliquing angle 0.00\n"
+ " flags normal\n"
+ " generation normal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}