$re = '/public\.(bg|cp)_.*/m';
$str = 'public.bg_table1
public.bg_table2
public.cp_table1
public.my_table1
public.user_action';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);