// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)public\.(bg|cp)_.*").unwrap();
let string = "public.bg_table1
public.bg_table2
public.cp_table1
public.my_table1
public.user_action";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}