const regex = /(?<!\*)\*[^*\s]+\*(?!\*)(?=(?:(?:[^$]*\$){2})*[^$]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\*)\\*[^*\\s]+\\*(?!\\*)(?=(?:(?:[^$]*\\$){2})*[^$]*$)', 'gm')
const str = `Lorem **Ipsum**(1) is *simply*(2) dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, \$ \\sqrt{2} **must be no bold **(3) *must be no italic *(4) \$ ****(5) **(6)...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}