re = /(?<!\*)\*[^*\s]+\*(?!\*)(?=(?:(?:[^$]*\$){2})*[^$]*$)/m
str = 'Lorem **Ipsum**(1) is *simply*(2) dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry\'s standard dummy text ever since the 1500s, $ \\sqrt{2} **must be no bold **(3) *must be no italic *(4) $ ****(5) **(6)...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end