using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<twas>(?<twisting>[5])|(?<armstand>[6]))?(?<direction>[1-4])(?<flying>(?(twas)[ ]?|[0-1]))?(?<summersaults>[(]?(?:[1-9]|1[0-2]?)[)]?)(?<twists>[(]?(?:[1-9]|1[0-2]?)[)]?)?(?<position>[a-e])";
string input = @"6273C";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}