re = /(?<twas>(?<twisting>[5])|(?<armstand>[6]))?(?<direction>[1-4])(?<flying>(?(twas)[ ]?|[0-1]))?(?<summersaults>[(]?(?:[1-9]|1[0-2]?)[)]?)(?<twists>[(]?(?:[1-9]|1[0-2]?)[)]?)?(?<position>[a-e])/i
str = '6273C'
# Print the match result
str.match(re) do |match|
puts match.to_s
end