using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]&[/]";
string input = @"http://www.website.com/link1/link2/link3
/sellerlistings/18865?ads=810157,810158,96746";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}