$re = '/^[0-9]&[/]/';
$str = 'http://www.website.com/link1/link2/link3
/sellerlistings/18865?ads=810157,810158,96746';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);