const regex = /^IMD(?:\+.*?){3}(?::.*?){3}(?<desc>[^:+']*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^IMD(?:\\+.*?){3}(?::.*?){3}(?<desc>[^:+\']*)', 'gm')
const str = `LIN+00010++079790040080030:SA'
PIA+1+079790040080030:SA'
IMD+F++:::DIN 7979 D Stahl blank | 8x30 Zylin'
QTY+12:10,000:PCE'
PRI+AAA:23,56:::100:PCE'
SCC+1'
QTY+1:10,000:+::'
DTM+2:20200223:102'
LIN+00020++079790040080040:SA'
PIA+1+079790040080040:SA'
IMD+F++:::DIN 7979 D Stahl blank | 8x40 Zylin'
QTY+12:10,000:PCE'
PRI+AAA:24,58:::100:PCE'
SCC+1'
QTY+1:10,000'
DTM+2:20200223:102'
LIN+00030++009128009060016:SA'
PIA+1+009128009060016:SA'
IMD+F++:::DIN 912 Stahl 8.8 blank | M6x16 Zyl'
QTY+12:100,000:PCE'
PRI+AAA:2,36:::100:PCE'
SCC+1'
QTY+1:100,000'
DTM+2:20200223:102'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}