# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^IMD(?:\+.*?){3}(?::.*?){3}(?<desc>[^:+']*)"
test_str = ("LIN+00010++079790040080030:SA' \n"
"PIA+1+079790040080030:SA' \n"
"IMD+F++:::DIN 7979 D Stahl blank | 8x30 Zylin' \n"
"QTY+12:10,000:PCE' \n"
"PRI+AAA:23,56:::100:PCE' \n"
"SCC+1' \n"
"QTY+1:10,000:+::' \n"
"DTM+2:20200223:102' \n"
"LIN+00020++079790040080040:SA' \n"
"PIA+1+079790040080040:SA' \n"
"IMD+F++:::DIN 7979 D Stahl blank | 8x40 Zylin' \n"
"QTY+12:10,000:PCE' \n"
"PRI+AAA:24,58:::100:PCE' \n"
"SCC+1' \n"
"QTY+1:10,000' \n"
"DTM+2:20200223:102' \n"
"LIN+00030++009128009060016:SA' \n"
"PIA+1+009128009060016:SA' \n"
"IMD+F++:::DIN 912 Stahl 8.8 blank | M6x16 Zyl' \n"
"QTY+12:100,000:PCE' \n"
"PRI+AAA:2,36:::100:PCE' \n"
"SCC+1' \n"
"QTY+1:100,000' \n"
"DTM+2:20200223:102' \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.