using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"John(?![^<]*<\/a>)";
string input = @"Let's talk about John. John is a nice guy and rocks. <a href=""www.john.com"">Click here to meet up John.</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}