re = /John(?![^<]*<\/a>)/
str = 'Let\'s talk about John. John is a nice guy and rocks. <a href="www.john.com">Click here to meet up John.</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end