import re
regex = re.compile(r"You\d:\d\d PM\n", flags=re.MULTILINE)
test_str = ("shape our society v\n"
"deep constituent\n"
"be bombarded by \n"
"creep into our personal space v\n"
"harass v\n\n"
"Do you think that advertising is now playing a major role in our knowledge of what we want?\n"
"What two types of advertisement are covered in this study? Can you think of an example of each of these?\n\n"
"Do you personally think there is one more successful advertising method than other? What personally sticks with you from an ad?\n"
"What constitutes a bad advertisement in your experience?\n"
"You1:24 PM\n"
"ethereal \n"
"frolick within the jungle v: carelessly walk, wander\n"
"You1:26 PM\n"
"Do you think that advertising plays on our existential anxiety? \n\n"
"Do you believe that advertising is inherently immoral? Why/ Why not?\n\n"
"to not have an inkling about sth v: have no idea\n"
"You1:29 PM\n"
"to cater to (our feelings) v: be aimed at \n"
"evoking adj\n"
"You1:30 PM\n"
"They sell an image of perfection\n"
"You1:34 PM\n"
"And the iPhone is instrumental in these plans\n"
"You1:36 PM\n"
"I think the important thing for us is the way we want to feel\n"
"We are caught\n"
"You1:48 PM\n"
"get in the way of my work v\n"
"get sidelined v: get distracted\n"
"persist in doing sth v\n"
"You1:50 PM\n"
"slick: elegant, luxurious, smart\n"
"You1:52 PM\n"
"ploy: a careful deviced plan to catch someone offguard regarding sth\n"
"gimmick: a show of opulence or a surprising demonstration to dazzle spectators or consumers\n"
"You1:53 PM\n"
"oblige (obláidsh)\n"
"You1:57 PM\n"
"mirror v: reflect, pair, match\n"
"You1:59 PM\n"
"hard-sell approach: appealing to the consumer's feelings to insert a product\n"
"trustworthiness")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)