import Foundation
let pattern = #"You\d:\d\d PM\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
shape our society v
deep constituent
be bombarded by
creep into our personal space v
harass v
Do you think that advertising is now playing a major role in our knowledge of what we want?
What two types of advertisement are covered in this study? Can you think of an example of each of these?
Do you personally think there is one more successful advertising method than other? What personally sticks with you from an ad?
What constitutes a bad advertisement in your experience?
You1:24 PM
ethereal
frolick within the jungle v: carelessly walk, wander
You1:26 PM
Do you think that advertising plays on our existential anxiety?
Do you believe that advertising is inherently immoral? Why/ Why not?
to not have an inkling about sth v: have no idea
You1:29 PM
to cater to (our feelings) v: be aimed at
evoking adj
You1:30 PM
They sell an image of perfection
You1:34 PM
And the iPhone is instrumental in these plans
You1:36 PM
I think the important thing for us is the way we want to feel
We are caught
You1:48 PM
get in the way of my work v
get sidelined v: get distracted
persist in doing sth v
You1:50 PM
slick: elegant, luxurious, smart
You1:52 PM
ploy: a careful deviced plan to catch someone offguard regarding sth
gimmick: a show of opulence or a surprising demonstration to dazzle spectators or consumers
You1:53 PM
oblige (obláidsh)
You1:57 PM
mirror v: reflect, pair, match
You1:59 PM
hard-sell approach: appealing to the consumer's feelings to insert a product
trustworthiness
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)