$re = '/%{(.*?)}(?=[^{}]*%{|$)/m';
$str = 'Hello %{{{friends}} and foes}, I am here to %{cause problems with my \'}\'s}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);