$re = '/(PackageQuantity:|(Servings)?PerContainer:|(Servings)?PerPackage:)(about|approx.)?(\d+)/';
$str = 'ServingsPerContainer:about11
PackageQuantity:approx.12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);