// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(PackageQuantity:|(Servings)?PerContainer:|(Servings)?PerPackage:)(about|approx.)?(\d+)").unwrap();
let string = "ServingsPerContainer:about11
PackageQuantity:approx.12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}