# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(\@\$.+\)//g;t' <<< "$16,500,000(@$2,500)
$34,000(@$11.00)
$214,000(@$18.00)
$12,684,000(@$3,800) "