using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\@\$.+\)";
string substitution = @"";
string input = @"$16,500,000(@$2,500)
$34,000(@$11.00)
$214,000(@$18.00)
$12,684,000(@$3,800) ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}