re = /,<([^>]+)>/
str = '<https://api.some.com/v1/monitor/zzsomeLongIdzz?access_token=xxSomeLongTokenxx==>; rel="monitor",<https://api.some.com/v1/services/xx/something-more/accounts/2345?access_token=xxSomeLongTokenxx==>; rel="parent"
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end