$re = '/^(.+?)(?:\s\(.+\))?$/m';
$str = 'some text (some parenthetical text)
some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);