re = /^(.+?)(?:\s\(.+\))?$/m
str = 'some text (some parenthetical text)
some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end