#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\b(0)\1+\b)(\+?\d{1,3}[. -]?)?\(?\d{3}\)?([. -]?)\d{3}\3\d{4}$"
Local $sString = "1234567098" & @CRLF & _
"+18173318732" & @CRLF & _
"+91981832670" & @CRLF & _
"91981832670" & @CRLF & _
"0000000001" & @CRLF & _
"123.456.7890" & @CRLF & _
"" & @CRLF & _
"22323j2323" & @CRLF & _
"123456789" & @CRLF & _
"0000000000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")