re = /^(?!\b(0)\1+\b)(\+?\d{1,3}[. -]?)?\(?\d{3}\)?([. -]?)\d{3}\3\d{4}$/m
str = '1234567098
+18173318732
+91981832670
91981832670
0000000001
123.456.7890
22323j2323
123456789
0000000000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end