using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-1]\d)|(2[0-3])):[0-5]\d:[0-5]\d";
string input = @"23:21:55
01:13:33
55:66:23
12:44:11
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}