#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[1-9]\d{3}(?: ?(?!s[ads])[A-Z]{2})?$"
Local $sString = "1234 AZ" & @CRLF & _
"1234 Ss" & @CRLF & _
"1234 sd" & @CRLF & _
"1234 sA" & @CRLF & _
"1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")