const regex = /^[1-9]\d{3}(?: ?(?!s[ads])[A-Z]{2})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]\\d{3}(?: ?(?!s[ads])[A-Z]{2})?$', 'gmi')
const str = `1234 AZ
1234 Ss
1234 sd
1234 sA
1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}