package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bDELIVER TO:\R\s*(\S+).*(?:\R.*){2}.*\h(\S+)`)
var str = `RECOVER FROM:
Company 1
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla
DELIVER TO:
Sypris Solutions, Inc.
Street 123
City ZIP US
Bla: Bla
Bla: Bla
Bla: Bla`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}