import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bDELIVER TO:\\R\\s*(\\S+).*(?:\\R.*){2}.*\\h(\\S+)";
final String string = "RECOVER FROM:\n"
+ "Company 1\n"
+ "Bla: Bla\n"
+ "Bla: Bla\n"
+ "Bla: Bla\n"
+ "Bla: Bla\n"
+ "Bla: Bla\n"
+ "Bla\n\n"
+ "DELIVER TO:\n"
+ "Sypris Solutions, Inc.\n"
+ "Street 123\n"
+ "City ZIP US\n"
+ "Bla: Bla\n"
+ "Bla: Bla\n"
+ "Bla: Bla";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}