$re = '/\bDELIVER TO:\r?\n[ \t]*(\S+).*(?:\r?\n.*){2}.*[ \t](\S+)/';
$str = 'RECOVER FROM:
Company 1
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla
DELIVER TO:
Sypris Solutions, Inc.
Street 123
City ZIP US
Bla: Bla
Bla: Bla
Bla: Bla';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);