import re
regex = re.compile(r"\bDELIVER TO:\r?\n[ \t]*(\S+).*(?:\r?\n.*){2}.*[ \t](\S+)")
test_str = ("RECOVER FROM:\n"
"Company 1\n"
"Bla: Bla\n"
"Bla: Bla\n"
"Bla: Bla\n"
"Bla: Bla\n"
"Bla: Bla\n"
"Bla\n\n"
"DELIVER TO:\n"
"Sypris Solutions, Inc.\n"
"Street 123\n"
"City ZIP US\n"
"Bla: Bla\n"
"Bla: Bla\n"
"Bla: Bla")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")