package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`".*?"|[^,]*`)
var str = `first,last,,4443334444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}