$re = '/".*?"|[^,]*/';
$str = 'first,last,,4443334444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);