$re = '/^http:\/\/www\.example\.com(?:\/example\/[^\/]+\/?)?\??.*$/m';
$str = 'http://www.example.com/example/anythinghere/
http://www.example.com
http://www.example.com/?argumentshere
http://www.example.com/example/anythinghere/?argumentshere';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);