re = /^http:\/\/www\.example\.com(?:\/example\/[^\/]+\/?)?\??.*$/m
str = 'http://www.example.com/example/anythinghere/
http://www.example.com
http://www.example.com/?argumentshere
http://www.example.com/example/anythinghere/?argumentshere'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end