$re = '~\bfrom\b.{1,20}\bFrance\b~i';
$str = 'These people came from some area in France';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);