re = /\bfrom\b.{1,20}\bFrance\b/i
str = 'These people came from some area in France'
# Print the match result
str.match(re) do |match|
puts match.to_s
end