$re = '/(\d*) ?(kg|ml|gallon).*(water|oil)/i';
$str = '1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);