// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\d*) ?(kg|ml|gallon).*(water|oil)").unwrap();
let string = "1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}