using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A( |$)";
string substitution = @"Amp";
string input = @"2.7A
A2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}