const regex = /A( |$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A( |$)', 'g')
const str = `2.7A
A2`;
const subst = `Amp`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);