$re = '/^(\d{5})\D{0,3}(\d{4})$/m';
$str = '43234-3423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);