const regex = /(?!\W)(http(s?):\/{2})?(www\.)?[a-z0-9-.]+?\.[cnoiegm][a-z]{1,2}(\/[^\s]*|(?=\W))?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\W)(http(s?):\\\/{2})?(www\\.)?[a-z0-9-.]+?\\.[cnoiegm][a-z]{1,2}(\\\/[^\\s]*|(?=\\W))?', '')
const str = `google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}