re = /(?!\W)(http(s?):\/{2})?(www\.)?[a-z0-9-.]+?\.[cnoiegm][a-z]{1,2}(\/[^\s]*|(?=\W))?/
str = 'google.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end