$re = '/\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d/m';
$str = 'Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack\'s number is (765) 452/1243.
The central number is 871/445/6197
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);