re = /(\s*\[+?\s*(\!?)\s*([a-z]*)\s*\|?\s*([a-z0-9\.\-_]*)\s*\]+?)?\s*([^\s]+)\s*/i
str = 'http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[ ! css | name ] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[!css] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[ css | name ] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css|name] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css|] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[|name] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end