# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?\\/)\d+-(.*)/$1$2/g;t' <<< "http://example.com/19731-la-preservacion-de-la-biodiversidad-es-crucial-para-frenar-la-desertificacion-en-zonas-aridas
http://example.com/633-afecta-la-crisis-alimentaria-ya-a-miles-de-personas
"