const regex = /(\d{1,2}:\d{2}[ap]m\s–\s\d{1,2}:\d{2}[ap]m)(\D*(?:\d(?!\d?:\d{2}[ap]m\s)\D*)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}:\\d{2}[ap]m\\s–\\s\\d{1,2}:\\d{2}[ap]m)(\\D*(?:\\d(?!\\d?:\\d{2}[ap]m\\s)\\D*)*)', 'g')
const str = `1:19pm – 10:33pm ate tacos 10:35pm – 11:38pm 12:40am – 1:24am took a nap`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}